Xpadder sequences slower than normal on Windows 10

Post Reply
Gnarkill
Posts: 6
Joined: 23 Mar 2021, 02:56

Xpadder sequences slower than normal on Windows 10

Post by Gnarkill »

On Windows 7 over the years I've created many sequences with Xpadder to train against specific combos/setups in fighting games on fba, fbneo, and mednafen. I recently moved to Windows 10 and noticed ALL sequences now come out slower than they should despite Xpadder test keys showing otherwise. Some I can fix by adjusting the delay to be less, however some that already had very short delays cannot go low enough to offset this so they are now impossible to do with Xpadder. I'm sure the problem is something Windows 10 did, I tried it on my Windows 10 laptop and had the same result.

Errol
Xpadder Xpert
Posts: 299
Joined: 02 Oct 2011, 19:48
Location: Strange Place
Contact:

Re: Xpadder sequences slower than normal on Windows 10

Post by Errol »

Disable Windows Defender Smart Screen. It's possible that is the culprit. Go in Task Manager and under the processes tab you'll see it there...right click and End process. It can be other issues but i think it's Windows Defender Smart Screen.

Gnarkill
Posts: 6
Joined: 23 Mar 2021, 02:56

Re: Xpadder sequences slower than normal on Windows 10

Post by Gnarkill »

I completely disabled Windows Defender Smart Screen. Unfortunately, it did not fix the problem.

Errol
Xpadder Xpert
Posts: 299
Joined: 02 Oct 2011, 19:48
Location: Strange Place
Contact:

Re: Xpadder sequences slower than normal on Windows 10

Post by Errol »

Restart Xpadder by right clicking on it and Run as Administrator. Hopefully that should solve the issue.

Gnarkill
Posts: 6
Joined: 23 Mar 2021, 02:56

Re: Xpadder sequences slower than normal on Windows 10

Post by Gnarkill »

Run as Administrator did not fix the issue.

Jonathan
Xpadder creator
Posts: 1640
Joined: 24 Aug 2009, 11:33
Location: England
Contact:

Re: Xpadder sequences slower than normal on Windows 10

Post by Jonathan »

Try closing Xpadder completely (via the tray icon)
Now right-click Xpadder.exe and select Properties and select the Compatibility tab
Now choose your previous version of Windows

If that doesn't help do you notice input delay via Xpadder in the fighting games when moving or performing single button actions or moving the mouse pointer around the Windows desktop?

Gnarkill
Posts: 6
Joined: 23 Mar 2021, 02:56

Re: Xpadder sequences slower than normal on Windows 10

Post by Gnarkill »

Jonathan wrote:
27 Mar 2021, 17:14
Try closing Xpadder completely (via the tray icon)
Now right-click Xpadder.exe and select Properties and select the Compatibility tab
Now choose your previous version of Windows
I have already have tried all of this and it didn't change anything. It's too difficult to tell if single button actions and moving the mouse pointer have this problem, though I assume they do.

Other things I've tried
- Enabling "Disable fullscreen optimizations"
- Using Xpadder version 2020.05.01 (I was using 2017.05.01)

Jonathan
Xpadder creator
Posts: 1640
Joined: 24 Aug 2009, 11:33
Location: England
Contact:

Re: Xpadder sequences slower than normal on Windows 10

Post by Jonathan »

I have received another message about timing issues in Windows 10.
They had a clever of assigning a key to a button and setting toggle and a turbo of 1s.
In a 20 second Notepad test in Windows 7 this output 21 keys whereas Windows 10 only output 13 keys

It would be useful if you could perform the same test. It would also be useful if anyone else can run the test successfully on Windows 10 to help determine if it is a Windows 10 issue affecting everyone.

Gnarkill
Posts: 6
Joined: 23 Mar 2021, 02:56

Re: Xpadder sequences slower than normal on Windows 10

Post by Gnarkill »

Jonathan wrote:
05 Apr 2021, 15:09
I have received another message about timing issues in Windows 10.
They had a clever of assigning a key to a button and setting toggle and a turbo of 1s.
In a 20 second Notepad test in Windows 7 this output 21 keys whereas Windows 10 only output 13 keys

It would be useful if you could perform the same test. It would also be useful if anyone else can run the test successfully on Windows 10 to help determine if it is a Windows 10 issue affecting everyone.
I did this test and here are my results:

Windows 7 = 21 keys
Window 10 = 14 keys

Jonathan
Xpadder creator
Posts: 1640
Joined: 24 Aug 2009, 11:33
Location: England
Contact:

Re: Xpadder sequences slower than normal on Windows 10

Post by Jonathan »

This is a tricky one. There are a number of technical reasons why this slowdown may be occurring.
If you run Xpadder with a blank profile, select any button in the controller layout, click to add an assignment, click Advanced, tick the Turbo box and set the time to 1.00s - the Robocop animation should show a bullet being fired every second.
If you then open the clock so you can see the second hand.
Is the animation firing every second or is it noticeably slower?

This test removes input simulation from the equation so it is just an empty loop.

Gnarkill
Posts: 6
Joined: 23 Mar 2021, 02:56

Re: Xpadder sequences slower than normal on Windows 10

Post by Gnarkill »

Jonathan wrote:
12 Apr 2021, 15:07
This is a tricky one. There are a number of technical reasons why this slowdown may be occurring.
If you run Xpadder with a blank profile, select any button in the controller layout, click to add an assignment, click Advanced, tick the Turbo box and set the time to 1.00s - the Robocop animation should show a bullet being fired every second.
If you then open the clock so you can see the second hand.
Is the animation firing every second or is it noticeably slower?

This test removes input simulation from the equation so it is just an empty loop.
Thankfully I can look at them side by side. It's very obvious the animation is noticeably slower on Windows 10.

Jonathan
Xpadder creator
Posts: 1640
Joined: 24 Aug 2009, 11:33
Location: England
Contact:

Re: Xpadder sequences slower than normal on Windows 10

Post by Jonathan »

Thanks for the feedback.
A quick update. I have found the issue but it is proving difficult to fix.
It involves the timing loop. Xpadder loops 100 times a second so each loop should be 10ms (0.01s). For each loop, after processing, the rest is filled with idle time.
On Windows 10 the idle time is not being handled correctly and can sometimes be more than requested. This results in the full second loop taking longer than a second and millisecond timing not being accurate.
For now the only workaround is to reduce the delay time in the turbo settings or reduce the timing slot values.
I have just made improvements to the timing in the latest development version but this only appears to have improved the accuracy for Windows versions prior to 10. I will keep hunting 8)

Post Reply

Return to “Xpadder not working in Windows”