Used to work, but now the gamepad image with all my buttons "falls down" and vanishes

Post Reply
Aropad
Posts: 1
Joined: 28 Jul 2022, 09:09

Used to work, but now the gamepad image with all my buttons "falls down" and vanishes

Post by Aropad »

Not sure how this started happening.

I have my controller set up with all my buttons. Used to have that 1, 2, 3, 4, 5, 6... buttons at the bottom to quick switch to my profiles.

Now when I load it up, it shows me my old controller and all the buttons... then everything 'falls down' off the bottom of the screen and I am left with a blank screen.

I can't seem to re add it. I don't know how to get it to detect anything. Windows says it notices my controller fine. I didn't change anything. Why do all my keys and settings just 'fall away' like that, and how do I fix this?

Jonathan
Xpadder creator
Posts: 1692
Joined: 24 Aug 2009, 11:33
Location: England
Contact:

Re: Used to work, but now the gamepad image with all my buttons "falls down" and vanishes

Post by Jonathan »

The falling away animation indicates that the controller has been disconnected. The tab in the top-left of the Xpadder main window will also turn red to indicate loss of connection.
When the controller is reconnected then the image and rise up again. The tab in the top-left will turn white.

If no controller is connected when Xpadder starts then the controller and buttons never appear so I suspect this is a driver issue and Xpadder loses the connection even though it is technically still there.

Which controller are you using?

Try clicking on the red tab in the top-left and then the Control Panel button. This will list the controllers that Windows can access. Is the controller still listed there? If not, then Windows has also lost connection with the controller.

Another test is to disconnect the controller, restart Windows, start Xpadder (the Xpadder screen should be empty with a searching animation). Now connect your controller into a different USB port and see if the controller images rises and stays.

Post Reply

Return to “Xpadder keeps installing/forgetting settings”